Help Center | Home

Ohio Medicaid Next Generation MyCare Changes

TOPIC: Effective 1/1/2026 NEW PAYER IDS and ROUTING for Ohio MyCare Plans

ISSUE:  In compliance with the Ohio Medicaid Next Generation MyCare Program changes, Etactics is prepared to comply with the current guidelines to route MyCare Plans for Anthem, Caresource, Molina and Buckeye via the One Front Door (OFD) for Claims, ERAs, Eligibility and Claim Status. 

DATE: 12/12/2025

ACTION TAKEN by ETACTICS

New Payer Ids for MyCare Plans EFFECTIVE 1/1/2026 for ALL Dates of Service

My Care Plan Name

Etactics Payer ID

ODM Payer ID 

MCDOH MY CARE - MOLINA

MCDMCMOL 

0021586

MCDOH MY CARE - CARESOURCE

MCDMCCS

0021599

MCDOH MY CARE - ANTHEM BCBS 

MCDMCABC

0022147

MCDOH MY CARE - BUCKEYE

MCDMCBCK

0021583

### Buckeye is not available for NEW Members, only grandfathered in for subscribers currently enrolled who did not elect a plan change


ACTION REQUIRED by CUSTOMER:

  1. After your last claim submission for 2025, Update your Payer Library for the MyCarePlans noted above. Claims received with these payer IDs BEFORE 12/31/2025 1pm est will be rejected for a NON ACTIVE PAYER ID. 
  2. Be sure you have a Payer /Plan to identify MYCare Plans, and include ‘My’ somewhere in the plan/payer name
  3. Be sure your MYCare Plans (Except UHC) are submitted with their 12 digit MMIS Policy number
  4. If you are in a county rolling out MyCare later in 2026 be sure to ARCHIVE this alert for future reference.

    Direct Scanning Issues Chromium Update v142

    We’ve received several tickets reporting scanning issues after a recent browser update to Chromium v142. This is a result of an update by Chromium that introduces new local network security rules that can block scanners from connecting. This update will affect all Chromium based browsers, including Chrome, Edge, Brave and Opera

    Examples of Issues:

    • The scanner is not showing up under source
    • Error: "An error occurred while scanning.  Please try again later."

    Cause:
    Chrome now blocks connections to “localhost” (127.0.0.1) unless users manually allow access. Since Dynamic Web TWAIN relies on local communication, scanning may fail until access is granted.

    Fix:

    1. Open your Dynamic Web TWAIN page in Chrome.
    2. Select the lock/settings icon in the browser address bar.
    3. Turn on Local Network Access.

    This must be done on every computer that uses a scanner. If scanning still doesn’t work after enabling Local Network Access, contact Dynamsoft for support.

    This issue is still developing. For updates, refer to:

      • Recent Articles

      • ERA Management Profiles, Rules, and CARC Crosswalk

        ERA Management Profiles, Rules, and CARC Crosswalk Overview ERA Management gives you control over how ERAs are interpreted and posted, helping you create consistent, predictable posting behavior across Payers. By using ERA Management Rules, you can ...
      • ERA Management Rule Examples

        Example 1 If you enter 253 as a CARC Rule, and a System Rule already exists for CO, the CO will take higher precedence over 253. Instead, enter CO253 in the CARC Rule which will take precedence over CO because it is more specific. Example 2 System ...
      • Institutional Billing (UB04)

        Institutional Billing (UB04) To access the option to create UB claims, you must choose Yes for Institutional Claims in System Settings. See Setup for UB04/Institutional Claims. Institutional (UB) Charge Entry On the Post Charge screen > Claim Type> ...
      • Calendar Tab Navigation

        Calendar Tab Uses The Calendar Tabs can be used: To add Appointments Search for Patient Appointments Search for Available Appointment Slots Determine which Resources and Facilities to see on your Calendar view. Print Superbills and Forms Print the ...
      • Claims Batch Uploading Errors

        If you are manually uploading your Claims batch without using the Job Scheduler, these are the warnings you might see. ERROR - DONE WITH WARNINGS This message indicates there are one or more Encounters with Local Edit Errors that will not be sent in ...
      • Popular Articles

      • Release Notes v 4.10

        The POPS 2.3 Release Notes can be found here. Patient Note Alert Enhancements Notes Notes and Alerts have been greatly enhanced. Category has replaced Type and Classification. New features include: Snooze-able Alerts, Effective/Expiration dates, ...
      • Release Notes v 4.8

        Release Notes v4.8 Charge Management Rule Actions Charge Management (CM) is a very popular System feature used to flag Encounters that need to be reviewed and/or edited before Claims are submitted. A frequent request has been to add functionality to ...
      • Release Notes v 4.7

        Release Notes v4.7 Fee and RVU Schedules Fee and RVU Schedules are now being stored in the Fee/RVU Management module (formerly Allowed Fee Schedules). The Charge Fee Schedule and Allowed Fee Schedule buttons no longer exist. This area will serve as a ...
      • Keyboard Shortcuts

        The System is designed for navigation with a keyboard in combination with a mouse. The following table shows shortcuts to navigate the system using your keyboard. Shortcuts Using Your Keyboard Shortcut Description Reference Batch 'Ctrl+Home' to open ...
      • Notify the Insurance when Attaching or Sending Paperwork

        You may send this with the first claim or you may resubmit the claim with this option. Indicate on the electronic claim that an attachment is being sent, such as an Operative Note via fax, email, or mail. Encounter Dashboard Charge Panel From the ...