Help Center | Home

Ohio Medicaid Next Generation MyCare Changes

TOPIC: Effective 1/1/2026 NEW PAYER IDS and ROUTING for Ohio MyCare Plans

ISSUE:  In compliance with the Ohio Medicaid Next Generation MyCare Program changes, Etactics is prepared to comply with the current guidelines to route MyCare Plans for Anthem, Caresource, Molina and Buckeye via the One Front Door (OFD) for Claims, ERAs, Eligibility and Claim Status. 

DATE: 12/12/2025

ACTION TAKEN by ETACTICS

New Payer Ids for MyCare Plans EFFECTIVE 1/1/2026 for ALL Dates of Service

My Care Plan Name

Etactics Payer ID

ODM Payer ID 

MCDOH MY CARE - MOLINA

MCDMCMOL 

0021586

MCDOH MY CARE - CARESOURCE

MCDMCCS

0021599

MCDOH MY CARE - ANTHEM BCBS 

MCDMCABC

0022147

MCDOH MY CARE - BUCKEYE

MCDMCBCK

0021583

### Buckeye is not available for NEW Members, only grandfathered in for subscribers currently enrolled who did not elect a plan change


ACTION REQUIRED by CUSTOMER:

  1. After your last claim submission for 2025, Update your Payer Library for the MyCarePlans noted above. Claims received with these payer IDs BEFORE 12/31/2025 1pm est will be rejected for a NON ACTIVE PAYER ID. 
  2. Be sure you have a Payer /Plan to identify MYCare Plans, and include ‘My’ somewhere in the plan/payer name
  3. Be sure your MYCare Plans (Except UHC) are submitted with their 12 digit MMIS Policy number
  4. If you are in a county rolling out MyCare later in 2026 be sure to ARCHIVE this alert for future reference.

    Direct Scanning Issues Chromium Update v142

    We’ve received several tickets reporting scanning issues after a recent browser update to Chromium v142. This is a result of an update by Chromium that introduces new local network security rules that can block scanners from connecting. This update will affect all Chromium based browsers, including Chrome, Edge, Brave and Opera

    Examples of Issues:

    • The scanner is not showing up under source
    • Error: "An error occurred while scanning.  Please try again later."

    Cause:
    Chrome now blocks connections to “localhost” (127.0.0.1) unless users manually allow access. Since Dynamic Web TWAIN relies on local communication, scanning may fail until access is granted.

    Fix:

    1. Open your Dynamic Web TWAIN page in Chrome.
    2. Select the lock/settings icon in the browser address bar.
    3. Turn on Local Network Access.

    This must be done on every computer that uses a scanner. If scanning still doesn’t work after enabling Local Network Access, contact Dynamsoft for support.

    This issue is still developing. For updates, refer to:

      • Recent Articles

      • Claims Batch Uploading Errors

        If you are manually uploading your Claims batch without using the Job Scheduler, these are the warnings you might see. ERROR - DONE WITH WARNINGS This message indicates there are one or more Encounters with Local Edit Errors that will not be sent in ...
      • Encounter Dashboard Notes Panel

        Encounter Dashboard Notes Overview Notes Overview Users can manually add Notes on the Encounter Dashboard. Some Notes that are added in other areas in the System can also be seen here. The System also creates Notes when certain actions are performed. ...
      • Incomplete Charge Review Overview

        What are Incomplete Charges? These are Charges that have not been completed to send to the Payer. They are created by: Charges that have been sent from your Chart Documentation System; Charges that are Imported with the Import Tool; or Charges that ...
      • Add or Modify Insurances in the Insurance Library

        Add or Modify Insurances in the Insurance Library When adding Payers to the Insurance Library, the System automatically creates numeric Insurance IDs unless you have elected to create your own. Create Your Own Insurance IDs Go to Admin on the Left ...
      • Automate Real-Time Claim Status with the Job Scheduler

        *Real Time Claim Status is a Premium Add-On Feature. Real-Time Claim Status (RTCS) allows the System to automatically check Claim Status responses on a designated schedule. This helps keep Claim Statuses up-to-date without requiring manual follow-up ...
      • Popular Articles

      • Release Notes v 4.10

        The POPS 2.3 Release Notes can be found here. Patient Note Alert Enhancements Notes Notes and Alerts have been greatly enhanced. Category has replaced Type and Classification. New features include: Snooze-able Alerts, Effective/Expiration dates, ...
      • Release Notes v 4.8

        Release Notes v4.8 Charge Management Rule Actions Charge Management (CM) is a very popular System feature used to flag Encounters that need to be reviewed and/or edited before Claims are submitted. A frequent request has been to add functionality to ...
      • Release Notes v 4.7

        Release Notes v4.7 Fee and RVU Schedules Fee and RVU Schedules are now being stored in the Fee/RVU Management module (formerly Allowed Fee Schedules). The Charge Fee Schedule and Allowed Fee Schedule buttons no longer exist. This area will serve as a ...
      • Keyboard Shortcuts

        The System is designed for navigation with a keyboard in combination with a mouse. The following table shows shortcuts to navigate the system using your keyboard. Shortcuts Using Your Keyboard Shortcut Description Reference Batch 'Ctrl+Home' to open ...
      • Notify the Insurance when Attaching or Sending Paperwork

        You may send this with the first claim or you may resubmit the claim with this option. Indicate on the electronic claim that an attachment is being sent, such as an Operative Note via fax, email, or mail. Encounter Dashboard Charge Panel From the ...